Sign in to follow this  
Followers 0

Help Troubleshooting A Broken Vm Broadband

12 posts in this topic

Posted · Report post

I would be obliged if users here could help me. Some medium level PC knowledge is required and a non Virgin Media internet connection.

I'm convinced VM have a routing problem for traffic going to Germany and the EU. Some traffic gets through, RDP, FTP but HTTP and Teamspeak and Arma2 traffic (presumably UDP) is either not getting there or very slow indeed. I rent a box in Germany with a company called Hetzner and they've been brilliant, but this weekend and now, I can't get much data to or from it from VM.

The IP is 213.239.206.79 and if non virgin customers could reply here with a copy/paste of a tracert to there, I'd be chuffed. While were at it, Virgin customers would be welcome to do the same. I suggest using the code tags to keep replies nice and tidy.

Thanks,

Paul

Share this post


Link to post
Share on other sites

Posted · Report post

What I expect to see is VM tracerts timing out about about hop 8 where the traffic goes abroad. Non VM customers should see a nice clean traceroute to the host in about 13 or 14 hops with no timeouts.

Share this post


Link to post
Share on other sites

Posted · Report post

213.239.206.79 is from Germany(DE) in region Western Europe

TraceRoute to 213.239.206.79 [213-239-206-79.clients.your-server.de]

Hop(ms)(ms)(ms)

IP AddressHost name

1 1 0 0 8.9.232.73 xe-5-3-0.edge3.dallas1.level3.net

2 0 0 0 4.69.145.190 vlan80.csw3.dallas1.level3.net

3 0 0 0 4.69.151.158 ae-83-83.ebr3.dallas1.level3.net

4 20 20 20 4.69.134.22 ae-7-7.ebr3.atlanta2.level3.net

5 34 33 34 4.69.132.86 ae-2-2.ebr1.washington1.level3.net

6 34 33 34 4.69.134.134 ae-71-71.csw2.washington1.level3.net

7 33 33 33 4.69.134.149 ae-72-72.ebr2.washington1.level3.net

8 113 113 113 4.69.137.53 ae-42-42.ebr2.paris1.level3.net

9 121 121 121 4.69.143.141 ae-47-47.ebr1.frankfurt1.level3.net

10 129 125 125 4.69.140.14 ae-91-91.csw4.frankfurt1.level3.net

11 122 122 122 4.69.154.199 ae-4-90.edge3.frankfurt1.level3.net

12 122 122 121 212.162.40.206 hetzner-onl.edge3.frankfurt1.level3.net

13 126 126 126 213.239.240.243 hos-bb1.juniper2.fs.hetzner.de

14 127 127 126 213.239.224.73 hos-tr3.ex3k8.rz13.hetzner.de

15 126 126 126 213.239.206.79 213-239-206-79.clients.your-server.de

Trace complete

Did it at

http://network-tools...=213.239.206.79

Doing it from the MSDOS prompt on my PC (via Easey net) does not connect and times out on hop 1!

Share this post


Link to post
Share on other sites

Posted · Report post

What I expect to see is VM tracerts timing out about about hop 8 where the traffic goes abroad. Non VM customers should see a nice clean traceroute to the host in about 13 or 14 hops with no timeouts.

Paste yours in too Paul :)

I tried it from my company connection, it pops into UUNET in Amsterdam, then Telia to Germany and it times out in Germany:


12  ge-7-2-0.xt2.ams2.alter.net (212.136.176.41)  47.352 ms  50.165 ms  32.094 ms

13  xe-11-0-0.br2.ams3.alter.net (146.188.4.58)  48.689 ms  42.996 ms  31.306 ms

14  ams-ge.telia.net (146.188.112.66)  32.441 ms  41.465 ms  32.374 ms

15  adm-bb2-link.telia.net (80.91.246.100)  34.932 ms

    adm-bb2-link.telia.net (213.155.130.44)  31.774 ms

    adm-bb2-link.telia.net (80.91.246.222)  31.832 ms

16  hbg-bb1-link.telia.net (213.155.130.223)  44.860 ms

    hbg-bb2-link.telia.net (80.91.248.211)  48.922 ms

    hbg-bb1-link.telia.net (213.155.130.223)  43.969 ms

17  ffm-bb2-link.telia.net (213.248.65.121)  42.680 ms

    ffm-bb1-link.telia.net (80.91.245.38)  44.962 ms

    ffm-bb2-link.telia.net (213.248.65.121)  43.061 ms

18  ffm-b2-link.telia.net (80.91.246.219)  42.580 ms

    ffm-b2-link.telia.net (80.91.247.167)  43.292 ms

    ffm-b2-link.telia.net (213.155.133.143)  53.455 ms

19  hetzner-ic-134650-ffm-b2.c.telia.net (213.248.92.82)  45.446 ms  46.557 ms  47.776 ms

20  hos-bb1.juniper2.fs.hetzner.de (213.239.240.243)  46.870 ms

    hos-bb1.juniper1.rz13.hetzner.de (213.239.240.240)  57.073 ms

    hos-bb1.juniper2.fs.hetzner.de (213.239.240.243)  80.080 ms

21  hos-tr2.ex3k8.rz13.hetzner.de (213.239.224.41)  49.919 ms  51.553 ms

    hos-tr4.ex3k8.rz13.hetzner.de (213.239.224.105)  47.309 ms

22  * * *

23  * * *

24  * * *

25  * * *

26  * * *

Then tried from Virgin Media - it times out at the same place... so looks like it's nothing to do with VM:

traceroute to 213.239.206.79 (213.239.206.79), 64 hops max, 52 byte packets

 1  10.213.4.1 (10.213.4.1)  8.391 ms  7.340 ms  7.978 ms

 2  watf-cam-1b-ge95.network.virginmedia.net (80.3.2.141)  8.317 ms  9.631 ms  17.190 ms

 3  watf-core-1b-ge-011-0.network.virginmedia.net (195.182.176.229)  8.535 ms  7.280 ms  9.906 ms

 4  popl-bb-1b-xe-701-0.network.virginmedia.net (212.43.162.142)  18.824 ms  10.607 ms  16.281 ms

 5  popl-bb-1a-ae0-0.network.virginmedia.net (213.105.174.229)  22.779 ms  11.594 ms  9.680 ms

 6  popl-tmr-1-ae4-0.network.virginmedia.net (213.105.159.2)  8.173 ms  9.655 ms  10.993 ms

 7  amst-ic-1-as0-0.network.virginmedia.net (213.105.175.6)  15.400 ms  38.411 ms  15.398 ms

 8  r1ams1.core.init7.net (195.69.144.210)  16.828 ms  26.935 ms  25.066 ms

 9  r1fra1.core.init7.net (77.109.128.153)  25.309 ms  28.669 ms  26.854 ms

10  gw-hetzner.init7.net (77.109.135.18)  51.589 ms  52.673 ms  25.782 ms

11  hos-bb1.juniper1.rz13.hetzner.de (213.239.240.240)  29.899 ms

    hos-bb1.juniper2.fs.hetzner.de (213.239.240.243)  36.633 ms  30.649 ms

12  hos-tr2.ex3k8.rz13.hetzner.de (213.239.224.41)  35.686 ms

    hos-tr3.ex3k8.rz13.hetzner.de (213.239.224.73)  45.302 ms

    hos-tr1.ex3k8.rz13.hetzner.de (213.239.224.9)  32.215 ms

13  * * *

14  * * *

15  * *

Looks like hetzner has a routing problem to me... just depends where you enter hetzner's network..

Also - you are not alone:

http://community.virginmedia.com/t5/General-broadband-questions/Routing-Issue-between-Virgin-Media-and-Hetzner/m-p/649443

and here:

As I said before though, the fact that I get it from a UUNET connection in Amsterdam makes me sceptical that it's anything to do with VM (my local connection is VM, but I'm VPNed into Amsterdam so logically not using VM at all..)

http://community.virginmedia.com/t5/Up-to-30Mb-and-50Mb-broadband/new-routing-issue-to-EU/td-p/643567

Share this post


Link to post
Share on other sites

Posted · Report post

Translated this in google:

http://www.hetzner-status.de/

Failure shared hosting server www184

Type: Fault message

Categories: Web hosting and managed server

Start: 8th August 2011 15:20:00 CEST

End: Unknown

Description: Due to a technical problem is the shared hosting server www184.your-server.de not currently reach.

Our technicians have been working hard on solving the problem.

Affected: Whether your domain is affected can be found by looking at the completion message or by a traceroute out to your domain.

Traceroutes as you can on the website www.traceroute.org perform.

In the trace route is then as

....

5 11 ms 11 ms 11 ms GigE 0.Hetzner.DHK.N-IX.net [195.85.217.16]

6 13 ms 12 ms 12 ms hos-bb1.juniper1.rz4.hetzner.de [213 239 240 200]

7 61 ms 94 ms 130 ms www184.your-server.de [% IP%]

Update: 8th August 2011 16:05:00 CEST

The server is accessible again

Looks to be a problem in germany (edit - although re-reading it it looks unrelated, but the same sort of trace routes are happening .. odd)

and from south africa (via traceroute.org:

traceroute to 213.239.206.79 (213.239.206.79), 20 hops max, 40 byte packets

1 mk2-svr1-vrrp35-32.p.nwu.ac.za (143.160.35.254) 0.514 ms 0.577 ms 0.617 ms

2 c6-usr1-xe0-0-2.p.nwu.ac.za (143.160.130.108) 0.685 ms 0.734 ms 0.724 ms

3 143.160.129.245 (143.160.129.245) 0.300 ms 0.320 ms 0.356 ms

4 mk1-igs01-eth0.p.nwu.ac.za (143.160.4.1) 0.551 ms 0.546 ms 0.535 ms

5 saix-gw01.p.nwu.ac.za (143.160.3.204) 0.903 ms 0.961 ms 0.886 ms

6 tpr-ip-esr-3-wan.telkom-ipnet.co.za (196.25.250.249) 7.050 ms 6.919 ms 6.188 ms

7 lon-ip-dir-telecity-gig-4-0-1025.telkom-ipnet.co.za (196.43.18.121) 196.831 ms 196.935 ms 196.967 ms

8 1329.xe-3-2-0.mpr2.lhr3.uk.above.net (213.161.92.181) 197.491 ms 197.561 ms 197.556 ms

9 ge-3-1-0.mpr1.lhr3.uk.above.net (64.125.27.153) 197.996 ms 197.967 ms 197.990 ms

10 so-1-1-0.mpr1.ams1.nl.above.net (64.125.28.198) 210.039 ms 210.072 ms 210.027 ms

11 xe-1-1-0.er1.ams1.nl.above.net (64.125.25.14) 216.077 ms 216.010 ms 216.114 ms

12 r1ams1.core.init7.net (195.69.144.210) 228.915 ms 228.300 ms 231.000 ms

13 r1fra1.core.init7.net (77.109.128.153) 245.768 ms 245.793 ms 245.700 ms

14 gw-hetzner.init7.net (77.109.135.18) 239.095 ms 238.645 ms 239.031 ms

15 hos-bb1.juniper1.rz13.hetzner.de (213.239.240.240) 243.596 ms hos-bb1.juniper2.fs.hetzner.de (213.239.240.243) 243.453 ms 243.411 ms

16 hos-tr2.ex3k8.rz13.hetzner.de (213.239.224.41) 243.570 ms hos-tr4.ex3k8.rz13.hetzner.de (213.239.224.105) 243.583 ms hos-tr3.ex3k8.rz13.hetzner.de (213.239.224.73) 243.446 ms

17 * * *

18 * * *

19 * * *

20 * * *

Done!

Share this post


Link to post
Share on other sites

Posted · Report post

Not sure I understand what you are talking about but, from BTInternet:

C:\Users\David>tracert 213.239.206.79

Tracing route to 213-239-206-79.clients.your-server.de [213.239.206.79]

over a maximum of 30 hops:

1 71 ms 99 ms 99 ms BThomehub.home [192.168.1.254]

2 34 ms 35 ms 36 ms esr2.kingston4.broadband.bt.net [217.47.46.141]

3 35 ms 34 ms 34 ms 217.47.46.30

4 37 ms 37 ms 37 ms 213.1.69.174

5 37 ms 37 ms 36 ms 217.32.24.234

6 38 ms 36 ms 37 ms 217.32.24.66

7 36 ms 36 ms 37 ms 217.32.24.182

8 38 ms 37 ms 37 ms acc2-10GigE-0-1-0-6.l-far.21cn-ipp.bt.net [109.1

59.249.222]

9 41 ms 39 ms 39 ms core1-te0-13-0-6.ilford.ukcore.bt.net [109.159.2

49.145]

10 37 ms 39 ms 39 ms peer1-xe10-0-0.telehouse.ukcore.bt.net [109.159.

254.122]

11 45 ms 38 ms 39 ms linx-1.init7.net [195.66.224.175]

12 44 ms 43 ms 44 ms r1ams2.core.init7.net [77.109.128.34]

13 62 ms 54 ms 54 ms r1fra2.core.init7.net [77.109.128.202]

14 53 ms 52 ms 52 ms r1fra1.core.init7.net [77.109.128.137]

15 54 ms 54 ms 54 ms gw-hetzner.init7.net [77.109.135.18]

16 59 ms 59 ms 59 ms hos-bb1.juniper2.fs.hetzner.de [213.239.240.243]

17 59 ms 59 ms 60 ms hos-tr3.ex3k8.rz13.hetzner.de [213.239.224.73]

18 59 ms 58 ms 59 ms 213-239-206-79.clients.your-server.de [213.239.2

06.79]

Trace complete.

Share this post


Link to post
Share on other sites

Posted · Report post

Paste yours in too Paul :)

Tracing route to 213-239-206-79.clients.your-server.de [213.239.206.79]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms DD-WRT [192.168.1.1]
2 10 ms 11 ms 19 ms cpc1-amer3-2-0-gw.15-2.cable.virginmedia.com [80
.0.168.1]
3 10 ms 7 ms 36 ms watf-core-1a-ge-014-1745.network.virginmedia.net
[80.3.1.57]
4 8 ms 38 ms 11 ms brnt-bb-1a-ge-320-0.network.virginmedia.net [212
.43.162.138]
5 9 ms 13 ms 24 ms brnt-bb-1b-ae0-0.network.virginmedia.net [213.10
5.174.226]
6 16 ms 16 ms 14 ms leed-bb-1a-as6-0.network.virginmedia.net [213.10
5.175.25]
7 34 ms 21 ms 23 ms tcl3-ic-1-ae0-0.network.virginmedia.net [212.43.
163.198]
8 * * * Request timed out.
9 28 ms 31 ms 29 ms vl835-rt1-ffm2.core.noris.net [213.95.14.2]
10 * * * Request timed out.
11 45 ms 35 ms 66 ms hos-bb1.juniper2.fs.hetzner.de [213.239.240.243]

12 * * * Request timed out.
13 36 ms 47 ms 33 ms 213-239-206-79.clients.your-server.de [213.239.2
06.79]

Trace complete.[/code]

Here's mine.

I also tried it in the other direction as I have RDP access to the box. That was even uglier!

Share this post


Link to post
Share on other sites

Posted · Report post

urg.. your VM traceroute looks weird (compaired to mine).. maybe you have got a VM routing problem..

Share this post


Link to post
Share on other sites

Posted · Report post

It definitely was (it's now fixed) a VM problem. Like Matthew I tracert'd from US based providers to Hetzner and it was fine. Likewise from other UK ISPs.

I know these things are dynamic, but it's interesting the Davids (Thanks DP) took 18 hops. My next door neighbour did it in 10 hops on Sky.

Translated this in google:

http://www.hetzner-status.de/

Failure shared hosting server www184

Type: Fault message

Categories: Web hosting and managed server

Start: 8th August 2011 15:20:00 CEST

End: Unknown

Description: Due to a technical problem is the shared hosting server www184.your-server.de not currently reach.

Our technicians have been working hard on solving the problem.

Affected: Whether your domain is affected can be found by looking at the completion message or by a traceroute out to your domain.

Traceroutes as you can on the website www.traceroute.org perform.

In the trace route is then as

....

5 11 ms 11 ms 11 ms GigE 0.Hetzner.DHK.N-IX.net [195.85.217.16]

6 13 ms 12 ms 12 ms hos-bb1.juniper1.rz4.hetzner.de [213 239 240 200]

7 61 ms 94 ms 130 ms www184.your-server.de [% IP%]

Update: 8th August 2011 16:05:00 CEST

The server is accessible again

Looks to be a problem in germany (edit - although re-reading it it looks unrelated, but the same sort of trace routes are happening .. odd)

Done!

Not convinced, Kiff. I still blame VM. :) BTW, the server isn't shared hosting, it's a dedicated box running MS Server 2008, although it does seem to use the same hop as mentioned by Hetzner.

We've not had any word from Virgin about this, I hate stealth fixes. I want them to come on and say "Ooops, yeah, t'was borked. Now fix0rd. Soz" as one of their chaps said back in 2008. Just before he 'left' the company. :)

Share this post


Link to post
Share on other sites

Posted · Report post

Doing it from the MSDOS prompt on my PC (via Easey net) does not connect and times out on hop 1!

Thanks Matthew. I used Domain tools too with the same result. It pointed the finger squarely at Virgin.

By the way, if it times out at hop one, your router or switch is set to not reply to ICMP ping requests. A tracert (trace route) is simply a series of pings to each of the nodes on the internet on the route your data is currently using. Not all nodes, your router in this case, reply to ping requests. Some others ignore them if they are very busy, which is why I asked for help during the quiet of a Monday afternoon.

Thanks to everyone who helped. It was as I suspected and now appears fixed.

Tracing route to 213-239-206-79.clients.your-server.de [213.239.206.79]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms DD-WRT [192.168.1.1]
2 7 ms 16 ms 31 ms cpc1-amer3-2-0-gw.15-2.cable.virginmedia.com [80
.0.168.1]
3 7 ms 20 ms 10 ms watf-core-1a-ge-014-1745.network.virginmedia.net
[80.3.1.57]
4 20 ms 40 ms 7 ms brnt-bb-1a-ge-320-0.network.virginmedia.net [212
.43.162.138]
5 37 ms 60 ms 64 ms brnt-bb-1b-ae0-0.network.virginmedia.net [213.10
5.174.226]
6 40 ms 13 ms 27 ms leed-bb-1a-as6-0.network.virginmedia.net [213.10
5.175.25]
7 39 ms 23 ms 22 ms tcl3-ic-1-ae0-0.network.virginmedia.net [212.43.
163.198]
8 46 ms 43 ms 31 ms te6-4-rt1-ldn1.core.noris.net [195.66.225.39]
9 42 ms 32 ms 53 ms vl835-rt1-ffm2.core.noris.net [213.95.14.2]
10 31 ms 46 ms 44 ms hetzner-gw.noris.net [213.239.242.249]
11 64 ms 35 ms 35 ms hos-bb1.juniper2.fs.hetzner.de [213.239.240.243]

12 34 ms 52 ms 35 ms hos-tr4.ex3k8.rz13.hetzner.de [213.239.224.105]

13 36 ms 49 ms 81 ms 213-239-206-79.clients.your-server.de [213.239.2
06.79]

Trace complete.
[/code]

It appears the noris.net node in London was failing just before the across the drink to Frankfurt. Virgin probably forgot to pay the bill. :)

Share this post


Link to post
Share on other sites

Posted · Report post

Apparently hetzner has a quite reliable infrastructure, but about a week ago I've experienced something similar on dozens of servers in Germany, France and Poland.

For about 3 hours I couldn't connect to ssh, 80% packet loss, maybe something similar, level3 for example. I'm using BT in Amersham

Thanks Matthew. I used Domain tools too with the same result. It pointed the finger squarely at Virgin.

By the way, if it times out at hop one, your router or switch is set to not reply to ICMP ping requests. A tracert (trace route) is simply a series of pings to each of the nodes on the internet on the route your data is currently using. Not all nodes, your router in this case, reply to ping requests. Some others ignore them if they are very busy, which is why I asked for help during the quiet of a Monday afternoon.

Thanks to everyone who helped. It was as I suspected and now appears fixed.

Tracing route to 213-239-206-79.clients.your-server.de [213.239.206.79]

over a maximum of 30 hops:


  1    <1 ms    <1 ms    <1 ms  DD-WRT [192.168.1.1]

  2 	7 ms    16 ms    31 ms  cpc1-amer3-2-0-gw.15-2.cable.virginmedia.com [80

.0.168.1]

  3 	7 ms    20 ms    10 ms  watf-core-1a-ge-014-1745.network.virginmedia.net

 [80.3.1.57]

  4    20 ms    40 ms 	7 ms  brnt-bb-1a-ge-320-0.network.virginmedia.net [212

.43.162.138]

  5    37 ms    60 ms    64 ms  brnt-bb-1b-ae0-0.network.virginmedia.net [213.10

5.174.226]

  6    40 ms    13 ms    27 ms  leed-bb-1a-as6-0.network.virginmedia.net [213.10

5.175.25]

  7    39 ms    23 ms    22 ms  tcl3-ic-1-ae0-0.network.virginmedia.net [212.43.

163.198]

  8    46 ms    43 ms    31 ms  te6-4-rt1-ldn1.core.noris.net [195.66.225.39]

  9    42 ms    32 ms    53 ms  vl835-rt1-ffm2.core.noris.net [213.95.14.2]

 10    31 ms    46 ms    44 ms  hetzner-gw.noris.net [213.239.242.249]

 11    64 ms    35 ms    35 ms  hos-bb1.juniper2.fs.hetzner.de [213.239.240.243]


 12    34 ms    52 ms    35 ms  hos-tr4.ex3k8.rz13.hetzner.de [213.239.224.105]


 13    36 ms    49 ms    81 ms  213-239-206-79.clients.your-server.de [213.239.2

06.79]


Trace complete.

It appears the noris.net node in London was failing just before the across the drink to Frankfurt. Virgin probably forgot to pay the bill. :)

Share this post


Link to post
Share on other sites

Posted · Report post

This is the first problem I've had since I got this Hetzner server and to be fair, it appears this was Virgins fault. I've had a couple of issues with some CZ sites, but that's probably not related - http traffic to Germany was fine, it's just UDP traffic that was failing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0